Categories


Tags


独立服务器win2003系统站点常见问题解答

独立服务器win2003系统站点常见问题解答

问题1:未启用父路径

症状举例:

Server.MapPath() 错误 ASP 0175 : 80004005

不允许的 Path 字符

/0709/dqyllhsub/news/OpenDatabase.asp,行 4

在 MapPath 的 Path 参数中不允许字符 ..。

原因分析:

许多Web页面里要用到诸如../格式的语句(即回到上一层的页面,也就是父路径),而IIS6.0出于安全考虑,这一选项默认是关闭的。

解决方法:

在IIS中 属性->主目录->配置->选项中。把”启用父路径“前面打上勾。确认刷新。

问题2:ASP的Web扩展配置不当(同样适用于ASP.NET、CGI)

症状举例:

HTTP 错误 404 - 文件或目录未找到。

原因分析:

在IIS6.0中新增了web程序扩展这一选项,你可以在其中对ASP、ASP.NET、CGI、IDC等程序进行允许或禁止,默认情况下ASP等程序是禁止的。

解决方法:

在IIS中的Web服务扩展中选中Active Server Pages,点击“允许”。

问题3:IUSR账号被禁用

症状举例:

HTTP 错误 401.1 - 未经授权:访问由于凭据无效被拒绝。

原因分析:

由于用户匿名访问使用的账号是IUSR_机器名,因此如果此账号被禁用,将造成用户无法访问。

解决办法:

控制面板->管理工具->计算机管理->本地用户和组,将IUSR_机器名账号启用。

问题4:NTFS权限设置不当

症状举例:

HTTP 错误 401.3 - 未经授权:访问由于 ACL 对所请求资源的设置被拒绝。

原因分析:

Web客户端的用户隶属于user组,因此,如果该文件的NTFS权限不足(例如没有读权限),则会导致页面无法访问。

解决办法:

进入该文件夹的安全选项卡,配置user的权限,至少要给读权限。关于NTFS权限设置这里不再馈述。

问题5:MIME设置问题导致某些类型文件无法下载(以ISO为例)

症状举例:

HTTP 错误 404 - 文件或目录未找到。

原因分析:

IIS6.0取消了对某些MIME类型的支持,例如ISO,致使客户端下载出错。

解决方法:

在IIS中 属性->HTTP头->MIME类型->新建。在随后的对话框中,扩展名填入.ISO,MIME类型是application。

来源:西部数码


Public @ 2016-04-30 16:13:23

服务器更换ip地址操作图解

很抱歉,作为AI,我无法提供操作图解。但是,通常更换服务器IP地址的步骤如下: 1. 登录服务器管理界面,找到网络配置选项。 2. 在网络配置中找到IP地址选项,点击编辑按钮。 3. 输入新的IP地址和子网掩码等信息,并保存更改。 4. 修改完IP地址后,可能需要重启服务器,以确保新的IP地址生效。 注意:在更换服务器IP地址前,要确保原IP地址不再使用,并通知相关人员或服务提供商更新IP地址

Public @ 2023-04-18 07:50:09

快云VPS如何远程登录?

远程登录是快云VPS使用基础。远程登录根据不同的VPS系统,有着不同的方式。快云VPS除基础型配置外,其他5种配置均支持Windows 2003、Windows 2008及CentOS 6.6。其中Windows 2003与Windows 2008同属Windows系列系统,远程登录方式相同,而CentOS 6.6属于Linux系列发行版本,需采用SSH方式远程登录,下面详细介绍一下,两类系统的远

Public @ 2021-12-05 16:13:15

VPS/服务器环境部署与网站程序安装

Discuz! X 是一款以 PHP 为编程语言,以 MySQL 为数据库,并使用 Apache/IIS/Nginx(任意一种即可) 提供 web 服务的产品。要搭建 Discuz! X 站点,服务器必须安装由 PHP、MySQL、Apache/IIS/Nginx 构成的环境。其中,IIS 主要用于 Windows 服务器,Apache、Nginx 多用于 Linux 服务器(即 LAMP 和 L

Public @ 2019-10-19 16:13:10

vps、云主机、独立服务器mysql开启root远程

注意:不支持共享IP主机(即不支持分配IP为10.100.1.*、192.168.*.*的共享ip主机)一、独立IP的Vps、云主机、独立主机首先远程登陆到服务器,不知道怎么远程请首先参考:http://www.west.cn/faq/list.asp?unid=417放行服务器3306端口:http://www.west.cn/faq/list.asp?unid=420警告:开启root远程登陆

Public @ 2010-03-24 16:13:28

更多您感兴趣的搜索

0.531871s