Categories


Tags


[原创]win2003、win2008升级为win2016保留数据重装恢复数据说明

请注意:本教程仅适用于我司网站管理助手预装环境以及对服务器环境有一定了解的用户使用,重装前请先详读本说明,然后再根据实际情况处理。C盘(桌面)有重要文件,请先提前复制备份到D盘。

分两种情况:

①、服务器使用了sqlserver数据库。先按本文步骤一处理。

②、服务器未使用sqlserver数据库。跳过步骤一。可以直接保留数据重装为:【Win2016 预装建站助手MSSQL2012】 然后按照步骤二的2.1开始处理。

步骤一. 安装了sqlserver数据库。

如果是手工创建的数据库,请提前自行备份好数据,比如复制备份mdf和ldf文件、备份导出为bak文件等。

备份以后可以参照1.2的步骤处理好目录权限,然后用管理助手重新创建数据库,用备份bak文件还原恢复。

管理助手创建的步骤如下

1.1)请将mssql中的所有数据库如图所示备份,注意保存到D:\mssql目录,非我司环境请自行导出到D盘,以便出现问题可用于恢复。

image.png

1.2)备份成功以后,再选择保留数据重装为【Win2016 预装建站助手MSSQL2012】 。

windows2016+sql2012 数据库恢复:

打开cmd命令行,打开方式:在计算机地址栏输入C:\Windows\System32\cmd.exe回车即可打开。

image.png

在命令行执行以下命令:

cacls D:\mssql /e /g westmssql:f /T

sc config MSSQLSERVER start= auto

权限重置以后将d:\mssql复制一份保留。然后再复制执行启动sqlserver服务

net start MSSQLSERVER

image.png

1.3)使用建站管理助手对mssql数据库进行同步。

如图所示,勾选数据库,点击同步按钮同步数据库。如果某个数据库数据存在异常,可用管理助手恢复步骤1.1中导出的备份。

image.png

1.4)mssql数据库同步完成后,打开编辑数据库,然后点击“修复”按钮修复数据库所有者。

image.png

再按步骤二中的2.1)2.2)的步骤通过建站管理助手重新部署php环境及恢复站点。

步骤二. 网站数据恢复。

2.1)打开管理助手,点击环境检测。根据需要勾选需要的环境(重要:先不要勾选mysql)。

image.png

2.1.1) mysql数据库处理

原来是mysql5.6的版本步骤

image.png

打开命令提示符,命令行里面依次执行

cacls D:\SOFT_PHP_PACKAGE\mysql5.6 /e /g mysql:f /T

net start mysql56

image.png

mysql5.1版本按以下步骤操作:

原win2003和win2008默认mysql是5.1版本,重装后的win2016默认是mysql5.6的服务,所以如果之前默认使用不是mysql5.6版本,需要重新安装mysql,步骤如下:

①、D:\SOFT_PHP_PACKAGE\mysql 将这个目录改名mysql_bak。

②、使用管理助手重新安装mysql5.1

image.png

安装完成以后,在开始里面找到“命令提示符”打开,然后再输入net stop mysql 停止mysql服务。

将D:\SOFT_PHP_PACKAGE\mysql_bak\data目录复制替换D:\SOFT_PHP_PACKAGE\mysql\data

在命令行窗口执行以下命令

cacls D:\SOFT_PHP_PACKAGE\mysql /e /g mysql:f /T

sc config mysql start= auto

net start mysql

此步骤是重置mysql目录权限并启动mysql服务。

打开管理助手,点击系统设置--全局参数  然后点击“尝试破解”重置mysql的root密码。

image.png

2.2)站点恢复。

站点和mysql用户的恢复请参考:https://www.west.cn/faq/list.asp?unid=608

如果有站点存在权限问题,单独编辑站点,勾选“重置权限”然后保存编辑。

image.png

以上操作执行完成以后再测试访问站点看看是否能够正常访问,访问无问题就表示迁移已经完成。

来源:西部数码


Public @ 2016-09-08 16:00:57

网站打开提示500调试显示错误方法(适用windows系统)

出现500错误的原因是很多的,一般来说,如果程序出错,那么在浏览器内会返回给用户一个友好的错误提示,统一称之为服务器500错误。 解决的方法就是您必须在http中能够正确的获得错误信息。方法为:请打开浏览器,选择工具,internet选项,高级,在高级中的浏览项目里面有一个"显示http友好错误提示"的复选框,请取消该复选框,这样您可以获得正确的错误提示。 在获得正确的错误提示

Public @ 2010-05-15 15:47:12

linux主机通过top看CPU性能指标

服务器变慢负载高时,需要先查看cpu负载是否过高,如果cpu负载高再看查看具体是什么进程占用cpu资源。一. cpu负载:通过top命令查看:图片.png主要看“load average”可理解为分别表示前 1、5、15分钟的平均负荷。通常1核的cpu不应超过4,如是4核cpu则不应超16(即:cpu核数 * 4),超过则说明负载较高存在异常。其他参数说明如下:us(user time) 

Public @ 2018-06-22 15:47:34

Windows Server的IIS和Apache性能

IIS和Apache都是流行的Web服务器软件,但它们的性能和特性不同。以下是对它们性能方面的比较: 1. 处理速度: IIS通常比Apache更快,尤其是在Windows环境下。这是因为IIS是Microsoft的官方Web服务器,紧密集成了Windows操作系统和ASP.NET技术。 Apache的性能则取决于它运行在的服务器硬件和软件配置。 2. 稳定性:IIS因为紧密集成Windows

Public @ 2023-06-27 09:50:57

KESION(.NET版)安装方法

1. 首先确定您的服务器或PC已经安装了.NET Framework 4.0或更高版本。 2. 下载KESION(.NET版)的安装文件,双击运行。 3. 在安装向导中,点击“下一步”进行安装。 4. 阅读许可协议后,如果同意,选择“我接受许可协议”,然后点击“下一步”。 5. 选择KESION(.NET版)的安装路径,点击“下一步”。 6. 选择需要安装的组件,然后点击“下一步”。 7. 如果您

Public @ 2023-04-27 08:50:08

更多您感兴趣的搜索

0.524763s