Categories


Tags


更改SQL Server 2005数据库端口方法

1.如果服务器的TCP端口更改为其他的端口,那么在客户端的配置工具中需要做如下的设置:

程序->Microsoft sql server 2005 ->配置工具->sql server configration manage ,如下图:

图片31.png

2.在网络配置中选择SQLEXPRESS协议如下图所示:

图片32.png

3.在右侧的TCP/IP中的属性中,协议对话框的内容,按照如下设置:

图片33.png

4.IP地址对话框中按照如下所示设置

图片34.png

5.IP2中的地址设置为客户端的IP地址,端口更改为服务器端SQL SERVER开发的端口。

图片35.png

6.在来设置客户端的协议的端口,界面如下所示

图片36.png

7.弹出的协议窗口中,更改默认的端口,设置如下图所示。

图片37.png

8.所有的设置完成之后,重新启动SQLEXPRESS服务。

图片38.png

9.照以上设置完成客户端端口更改,在程序中的数据库连接字符串也应该做相应的更改,否则还是无法连接打数据库。

Provider=SQLNCLI.1;Persist Security Info=True;User ID=****;Password=**;Initial Catalog=tablename;Data Source=202.000.000.000,3533.

来源:景安


Public @ 2012-03-02 15:47:48

Http 403.6 - Forbidden 错误解决办法

403.6 禁止:客户端IP 地址被拒绝 解决此错误的步骤如下: 1. 确认您输入了正确的 IP 地址或用户名/密码。 2. 对Internet服务提供商 (ISP) 的代理进行ping测试,以验证您使用的 Proxy 服务器可以让您正常访问网站。 3. 尝试使用其他网络,以确保网络连接正常。 4. 使用管理员账户进行登录,以确定错误是否仍然存在。 5. 检查您的IIS服务器上的访

Public @ 2023-02-24 00:28:17

win2003、win2008升级为win2012保留数据重装恢复数据说明

请注意:本教程仅适用于我司网站管理助手预装环境以及对服务器环境有一定了解的用户使用,重装前请先详读本说明,然后再根据实际情况处理。C盘(桌面)有重要文件,请先提前复制备份到D盘。如果要升级win2016可以参考:https://www.west.cn/faq/list.asp?unid=2446分两种情况:①、服务器使用了sqlserver数据库。先按本文步骤一处理。②、服务器未使用sqlserv

Public @ 2013-04-12 16:00:54

SQL Server数据库启动报错1068解决办法

1、运行sqlcmd,执行下面命令 EXEC xp_readerrorlog 0, 1, N' Socket 9.x.x.x', NULL, NULL, N'ASC' 2、记下当中的出错消息,通常以“Login failed for user”,来帮助定位出问题所在 3、如果该问题和SQL Server的日志连接有关,可以通过以下命令来查看是否存在该日志连接: SELE

Public @ 2023-03-01 07:00:18

SQL Server的Inner Join及Outer Join

--- **Inner Join:** 内连接(Inner Join)是通过比较表中字段之间的关系,把两个或多个表中符合指定关系的数据行连接起来,查询结果只有当两个表中同时存在满足指定关系的数据记录时,才会被检索出来。它主要是利用“=”操作符的结果作为连接的依据。内连接可以是一对一(One-to-One)或一对多(One-to-Many)关系,它们可以分别称为单值内连接(Scal

Public @ 2023-03-03 14:48:23

更多您感兴趣的搜索

0.564763s