Categories


Tags


linux nginx 网站访问提示502 Bad Gateway

从日志报错分析,是php线程打开文件句柄受限导致的,解决办法:

1、提升服务器的文件句柄打开打开

vi /etc/security/limits.conf 底部加上

* soft nofile 51200

* hard nofile 51200

vi /etc/sysctl.conf  底部添加

fs.file-max=51200

2、提升nginx的进程文件打开数

vi /www/wdlinux/nginx/conf/nginx.conf

worker_rlimit_nofile 5120; 改成worker_rlimit_nofile 51200;

3、修改php-fpm.conf文件,主要需要修改2处。

vi /www/wdlinux/etc/php-fpm.conf

改成下面的值

<value name="max_requests">10240</value>

<value name="rlimit_files">51200</value>

4.设置php-fpm自动启动

vi /etc/rc.local 最后增加

/etc/init.d/php-fpm start

完成之后reboot重启下服务器

ulimit -n 查看

来源:西部数码


Public @ 2019-03-13 15:47:43

快云服务器系统盘扩容教程(Win2003系统)

1.打开CMD命令框,输入:diskmgmt.msc,按回车键;006.png2.磁盘管理界面007.png3.Windows2003需要用分区工具来扩展,具体操作如下a.安装分区助手008.pngb.安装完成后009.png4.点击进入分区助手;010.png5.右击选择合并分区;011.png6.合并后点击提交按钮;012.png7.完成,可在计算机管理中的磁盘管理查看013.png来源:景安

Public @ 2017-07-20 16:13:12

云服务器添加多IP操作步骤(Windows&;Linux系统)

1. 登录云服务器控制台,进入网络和安全模块,选择弹性公网IP。 2. 在弹性公网IP列表中,点击申请弹性公网IP,填写相关信息,如带宽、计费方式等。 3. 申请完成后,选择已申请的弹性公网IP,点击绑定云服务器,选择需要绑定的云服务器实例并确认即可。 4. 对于Windows系统,进入控制面板,选择网络和Internet,点击网络和共享中心。在左侧窗口中点击更改适配器设置,在需要添加多个I

Public @ 2023-04-08 01:51:30

linux nginx 网站访问提示502 Bad Gateway

502 Bad Gateway错误通常是由于Nginx无法连接到您的应用程序服务器而导致的。主要是因为应用程序服务器未能正确响应Nginx的请求。以下是一些您可以尝试的解决方法: 1. 检查应用程序服务器是否已启动,并且正在监听正确的端口。如果不是,请启动应用程序服务器或更改其配置以监听正确的端口。 2. 检查Nginx配置文件中的upstream配置是否正确。确保upstream配置指向您的

Public @ 2023-04-14 14:50:31

更多您感兴趣的搜索

0.427361s