Categories


Tags


网站打开提示500调试显示错误方法(适用windows系统)

出现500错误的原因是很多的,一般来说,如果程序出错,那么在浏览器内会返回给用户一个友好的错误提示,统一称之为服务器500错误。 解决的方法就是您必须在http中能够正确的获得错误信息。

方法为:请打开浏览器,选择工具,internet选项,高级,在高级中的浏览项目里面有一个"显示http友好错误提示"的复选框,请取消该复选框,这样您可以获得正确的错误提示。 在获得正确的错误提示之后,您就可以根据该错误提示检查您具体的出错原因了。根据出错的具体原因,再进行相应调试即可解决。

图片.png

WINDOWS2008/2012 IIS7.5 只是设置ie客户端还不行,还需要对服务器端进行设置,设置开启详细错误显示步骤:

开IIS7.5管理器--点击您需要设置的站点-- 错误页 -- 点击 右侧“编辑功能设置”,修改为  详细错误 保存即可,如图设置:

1.jpg

ASP的程序还需要多做一步设置:

点击需要设置的站点--ASP选项卡  调试属性中 将错误发送到浏览器 选择true

1.jpg

来源:西部数码


Public @ 2010-05-15 15:47:12

Linux扫盲篇:CentOS、Ubuntu、Gentoo

CentOS、Ubuntu和Gentoo是几个常见的Linux发行版,它们各有特点和适用场景。 1. CentOS:CentOS是基于Red Hat Enterprise Linux (RHEL)源代码构建的一个免费而开放源代码的Linux发行版。它以稳定性和安全性而闻名,被广泛用于服务器和企业环境。CentOS的软件包管理系统是使用yum,它提供了大量的软件包和工具,以满足服务器环境的需求。C

Public @ 2023-06-30 01:50:22

windows 2003 64位系统php运行报错:1% 不是有效的 win32 应用程序

问题一:php运行报错:1% 不是有效的 win32 应用程序php环境配置完毕后,运行html成功,但运行php就报错,错误提示是“1% 不是有效的 win32 应用程序”,英文报%1 is not a valid Win32 application。第一次碰到这样的问题,经过搜索和试验,问题终于解决。报错原因:由于在64位操作系统里,默认配置下,IIS工作在64位模式下,这会让许多32位的应用

Public @ 2018-05-05 15:47:15

windows系统修改远程端口

为了增加服务器安全性,建议将默认开通服务器后的端口修改下,一般建议在1000--65535之间为佳必须按照下面顺序依次完成两步操作,否则服务器可能因为防护墙没有放行端口,造成不能远程如果为弹性云服务器,可以vnc登录检查设置1、防火墙放行新的远程端口:windows2003系统       下载 http://downinfo.myhostadmin.net

Public @ 2011-06-17 15:47:14

Windows Server的IIS和Apache性能

我曾经在《Windows服务器下的IIS和Apache性能比较》一文中比较了IIS和Apache的一些性能比较,并实际搭建了一个Apache+MySQL+PHP的平台,我当时的初步比较是两者在静态HTML的处理能力上基本相同。但是,经过我在实际网站上运行Apache+MySQL+PHP一段时间后,我发现在Windows Server 2003的环境下,Apache 2.2.6的稳定性的确不如IIS

Public @ 2021-12-12 16:01:02

更多您感兴趣的搜索

0.562425s