Categories


Tags


Linux操作系统破解Mysql密码的方法

(1) service mysqld stop  //先停止mysql服务

(2)然后打开mysql配置文件/etc/my.cnf.在【mysqld】下面添加一行代码:skip-grant-tables。这行代码意思就是跳过跳过授权表,即是可以跳过密码验证直接进入数据库。

图片1.png

(3) service mysqld restart //重启mysql数据库。假如不重启的话,不会生效。

mysql -uroot -p  //此时直接回车,既可以进入数据库。

出现mysql>就说明你已经进入到mysql数据库里了。

图片2.png

(4)进数据库后,use mysql //选择mysql这个库,因为mysql的root密码存放在这个数据库里。

show tables  //查看下mysql库里有哪些表,我们需要操作的用户名密码都在user表里。

desc user  //查看下user表有哪些字。

图片3.png

图片4.png

(5)更改root密码。

update user set password=password('123456') where user="root";  //用户选root,可以随便更改成任意密码,我这里设置的123456,password()是mysql密码加密的一个函数。

flush privileges;   //刷新下密码,使更改的生效。

exit  //退出数据库。

图片5.png

(6)退出数据库,重新登录

mysql -uroot -p   //回车输入刚刚更改的密码,就能进去了。

然后再次进入配置文件vi /etc/my.cnf 把skip-grant-tables去掉。

图片6.png

(7)注意更改后一定记得到my.cnf里把skip-grant-tables去掉,不然下次重启mysql后,又变成不需要密码直接进去了。

来源:景安


Public @ 2016-11-10 15:46:47

在IIS7下使用ASP连接ACCESS数据库时提示如下错误的处理方法

“/”应用程序中的服务器错误。未在本地计算机上注册“microsoft.jet.oledb.4.0”提供程序。这是由于我们使用的Win2008系统是64位的,以前Win2003是32位。有以下两种解决方法:1、修改连接数据库的代码:如原代码是DataPath = "App_Data/#data.mdb";String constring = "provider=mic

Public @ 2019-02-13 15:46:38

vps、弹性云手工创建MSSQL数据库(sqlserver2000版本)

1、我司的VPS一般都默认开通了MSSQL数据库,如果处于停止状态可以点击:开始→运行,输入services.msc,找到“MSSQLSERVER”服务,点“启动”,如图:2、点击开始→程序→Microsoft SQL server →企业管理器,打开数据库,右键点击“新建”。3、名称里默认输入一个数据库名称,建议用新建网站的的FTP加其他数字或者字母的组合,方便管理,如:myweb_mssql。

Public @ 2018-04-04 15:46:40

Mysql服务启动1067错误解决办法

Mysql密码忘记后因修改了mysql密码导致启动mysql出现了1067错误。方法一:启动服务的时候出现“windows无法启动mysql服务(位于本地计算机上。错误1067:进程意外终止)”查看下系统日志找寻mysql的相关错误可以发现。image.png图片1.png事件查看器中-应用程序下mysql错误的详情显示Default storage engine(InnoDB) is not a

Public @ 2009-08-29 15:46:47

更多您感兴趣的搜索

0.490967s