Categories


Tags


独立主机/VPS手工还原MSSQL数据库(sqlserver2000版本)

1、首先请保证您的备份文件是bak文件,并且备份文件能够正常还原。

2、打开“企业管理器”→“数据库”,选择您要还原的数据库,右键“所有任务”→“还原数据库”。如图:

3、如果需要还原以前备份过的文件,直接在“还原”选择“数据库”,然后在下方选择要还原的备份即可,如果是从其他地方上传或者复制过来的,请选择“从设备”还原。点“添加”,添加您需要还原的备份文件。如图:

4、点击确定后,点还原数据库上的“选项”查看恢复后数据库的路径,有时可能会还原失败,可以勾选“在现有数据库上强制还原”,至此,数据库还原的过程就讲完了。如图:

5、如果您已经有MDF和LDF文件,可以用数据库的附加功能进行附加。首先将您的数据库mdf和ldf文件上传到服务器的某个目录(一般不要放在系统盘,以免系统损坏造成数据丢失),比如d:\mssql目录,并给该目录mssqluser的完全控制权限。然后打开企业管理器,右键点击“数据库”——“所有任务”——“附加数据库”,如图:

点击“...”添加需要附加的mdf文件,并指定要附加的数据库名和数据库所有者如图:

点击确定附加数据库成功,如图:

注意,如果放在其他目录,务必保证该目录先加上mssqluser的完全控制权限,否则还原或备份会失败。保存备份的目录也必须有这个权限!!

来源:西部数码


Public @ 2013-06-08 15:46:41

windows系统MySQL 5.7 解压缩版安装配置方法

1. 下载MySQL 5.7解压缩版,解压到本地磁盘。 2. 定位到MySQL解压缩目录下面的bin目录,打开该目录。 3. 在bin目录下创建一个my.ini文件,用来配置MySQL属性。 4. 打开my.ini文件,写入以下内容,其中basedir和datadir的路径需要根据你的自己的安装目录进行配置。 [mysql] # 设置mysql客户端默认字符集 de

Public @ 2023-04-06 14:00:54

源文件方式恢复mysql数据库(适用虚拟主机、云主机)

1. 首先,下载备份文件。通常,MySQL备份文件是以.sql或.gz格式进行存储的。 2. 登录MySQL控制台,创建一个空的数据库,并为其指定一个名称。 3. 然后,通过SSH或FTP将备份文件上传到服务器。请确保文件在服务器上的正确路径可以访问。 4. 使用以下命令将备份文件还原到新创建的数据库中: ``` mysql -u your_username -p your_passwor

Public @ 2023-06-02 03:50:14

mssql数据库在更换服务器时如何转移数据?

Mssql数据库强烈推荐跟网站放在同一个机房内,跨机房远程调用数据时会非常慢且不稳定。如果您的mssql数据库需要更换机房时,请按如下流程转移数据库的内容:1.升级前先对数据库做好备份:(升级过程中不要继续往原服务器中写入新数据)备份流程:登录管理中心>Mssql数据库>管理然后点“备份”,成功后点“下载备份”,即可将该bak格式的数据库备份下载到您本地的电脑上。2.升级:登录管理中心

Public @ 2017-10-08 15:46:43

独立主机/VPS手工 新建/还原mssql2005数据库

首先、点击桌面的“SQL Server Management Studio”打开,sql2005的管理器,点击“连接”登录,如图:一、新建数据库1、新建数据库右键点击“数据库”——“新建数据库”,如图:填写数据库名,如mydata,选择数据库保存路径,一般可以保持默认地址,点击“确定”。2、新建用户右键点击“安全性”——“登录名”——“新建登录名”,如图:填写登录名,如mydata。选择“SQL

Public @ 2022-04-04 15:46:42

更多您感兴趣的搜索

0.454185s