Categories


Tags


防止ASP Session丢失的方法

也许很多ASP开发者都会遇到这样的情况:在会话期间(session)无故丢失sessio n。换而言之,丢失了SessionID,同样session级的变量也会丢失。

很多session丢失的原因是因为错误的程序或者是错误的虚拟目录结构。

SessionID 的改变有下面几个原因。

原因一:

Netscape的浏览器会认为"/App/user.asp"跟"/app/user.asp"是两个不同的程序。它会自动地开始一个新的会话期(new session)。所以,才你的网站上一定要统一字母的大小写。

原因二:

另外一个是原因是 Session.Timeout 的值。

Timeout这个属性是用来设置Session的超时时间的,一分钟为单位。假如一个用户,在一个Timeout的时间内没有刷新或者请求页面,那么会话就会结束(the se ssion ends)。当你再次请求页面的时候,一个新的会话有会开始。

确信Timeout的值,是分钟的。

格式: Session.Timeout [ = nMinutes]

原因三:

假如用户把他们的浏览器的cookie关了,当然session就不能保持。因为session的保持是要靠cookie的。

要保持Session的状态,浏览器就必须支持cookie,而且在打开的状态。你当然可以用其他的方法

原因四:

常犯的错误就是,建立了错误的目录结构。像下面的目录结构:

root  放了global.asa

\virtual_root  没有global.asa

\another_virtual_root  没有global.asa

调用两个virtual roots的页面,就会执行相同的global.asa(root上的那个)

另外的一个目录结构:

root  没有global.asa

\virtual 放了global.asa

\another_virtual_root 另外一个global.asa

每一个不同目录下的global.asa都会各自执行,当然执行的代码就不同了。不过如果里面的代码一样,就令当别说。:)

所以你在请求不同目录下页面,将会导致不同的global.asa被执行。不同的变量被调用,不同的session id被建立....之前的有用的信息都被破坏了。

下面是详细的解释:

当你先浏览子虚拟程序上的页面(child virtual application),然后再去浏览子虚拟程序的上一级的父虚拟程序(parent virtual root)的页面。那些变量就会丢失、破坏。看下面的表格:

请求                     子程序1丢失    子程序2丢失

先请求Root                      不会          不会

只在子程序1之前请求Root         不会           会

只在子程序2之前请求Root          会           不会

最后请求Root                     会            会

有一个注册表的键值(registry entry),叫CheckForNestedVroots(缺省为 1)。是设ASP是否去检测其他目录里的global.asa文件。

假如一个页面被请求,但是如果在这个被请求页面的同一目录里没有global.asa这文件,那么asp就会去上级的目录里找。ASP设计就是这样的。另一方面,假如application被请求的页面是在root的话,而global.asa也在root,那么ASP就会执行这个在root上的global.asa文件。没有必要去找子目录下的global.asa文件了。

Internet 服务管理器,可以把一个目录设成虚拟的目录,这样的目录是可以拥有自己的global.asa文件,当然Application_OnStart和Session_OnStart是少不了的(废话)。

这是个例子。他们都有Global.asa

C:\InetPub\wwwroot <Home>

Global.asa

C:\InetPub\wwwroot\Test2 (Nested)

Global.asa

C:\InetPub\wwwroot\Test2\Test3 (Nested)

Global.asa

C:\InetPub\wwwroot\Test4

Global.asa

注意:

如果Global.asa文件web请求时是要求认证的话,那么在Global.asa文件的Sessi on_onStart过程里初始化的变量将会是空的。如果你的global.asa的权限真的是这样设的话,那么将会带来很多的麻烦。例如你会见到这样的错误信息:

Microsoft OLE DB Provider for ODBC Drivers error '80004005 [Microsoft][ODBC Driver Manager] Data source name not found and no def ault driver specified /<web name>/<asp filename>.asp, line xx

这就是因为Session_onStart里面初始化的session变量是空的(根本就没有初始化)。

另外:这个问题在win95上不存在。更准确的是说,像在FAT这样的,没有文件权限设置的文件系统里,没有这样的问题。所以NT的NTFS是有这样问题的但,win9 5,98的就没有。

所以,你必须为Global.asa文件设置Internet匿名读取的权限,这样才保证问题不会发生。

来源:月光博客


Public @ 2009-09-01 15:46:30

VPS、弹性云使用phpmyadmin导入导出MySQL数据库

1. 登录phpmyadmin 使用VPS或弹性云服务器,首先需要登录phpmyadmin控制面板。访问网站的URL后,并在网站后加上“/phpmyadmin”即可进入登录页面。输入正确的用户名和密码进行登录。 2. 进入数据库 进入phpmyadmin控制面板后,会显示所有的数据库。选择要导入或导出的数据库并进入。 3. 导出MySQL数据库 要导出MySQL数据库,选择导航栏上的“导

Public @ 2023-04-17 09:00:11

IIS服务器手机访问不信任解决方法

如果您的IIS服务器无法被手机访问,可能是因为您的手机设备不信任服务器的证书。以下是一些解决方法: 1. 安装可信任的证书:您可以将服务器证书安装到手机设备上,以确保设备信任服务器。您可以通过将证书文件发送到手机设备并按照设备的安装指南进行操作来完成安装。 2. 使用公共CA颁发的证书:如果您的服务器使用了自签名证书,您可以考虑从公共CA(Certificate Authority)购买证书。

Public @ 2023-07-24 05:00:26

在ASP程序中调用Web Service

可以采用以下步骤来在ASP程序中调用Web Service: 1. 在ASP程序中添加对Web Service的引用。可以使用``元素或``元素,也可以使用Server.CreateObject函数。 示例代码: ``` ``` 2. 调用Web Service的方法。调用方法时,需要传递参数。可以通过设置`webService`对象的属性或使用方法的参数传递方式来传递参数。 示例代码

Public @ 2023-04-13 10:50:48

ASP中的进度条功能

用过软件的朋友都知道,进度条是一个优秀软件的重要组成部分。它 的存在能够使用户及时掌握程序的运行进度,确认应用程序正常工作。可 是ASP中似乎没有上述标准控件,控制起来也比较麻烦。那么如何实现进 度条呢?以下是本人的一些观点(仅供参考)我们通常在用ASP处理程序(指的是写文件或操作数据库)的时候,会 专门用一个页面(*.asp)去处理或控制这些程序,当处理完毕的时候再跳 转到显示页面。这时我们就可

Public @ 2022-02-06 15:46:28

更多您感兴趣的搜索

0.434508s