Categories


Tags


WordPress生成HTML静态化网站

十多年前,我写过一个“WordPress的静态化方法”,使用的是一个名为cos-html-cache的插件实现。

这个插件非常简洁小巧,直接在原网站上生成首页和文章页的html文件,不过,这个插件只支持文章静态化,不支持页面、标签和分类的静态化,之后也再没有过更新。

后来,我想到过利用WordPress插件导出全静态化网站的方法,用这个方法,对于少量文章挺方便,但文章数量一旦多了,就经常出错。

后来,我看到有人在cos-html-cache插件的基础上又开发了一个插件,名叫Super Static Cache,我用了一下,发现其BUG较多,只有Rewrite模式是可以正常使用的,在这个模式下,可以将首页、文章页、单页、分类页、Tag页都生成静态化文件,并保存在一个名为super-static-cache的目录下,直接复制这个目录即可得到一个静态化网站。

修复BUG的方法很简单,必须选择“Direct模式”后,将下面一行代码注释掉即可。其“Direct模式”功能实际和cos-html-cache一样,但实现了页面、标签和分类的静态化。

$rules = __('Your server type is not detected, Please visit https://www.hitoy.org/super-static-cache-for-wordperss.html for help.','super-static-cache');

因此,一个更简单的生成静态化网站的方法来了,先在网站安装Super Static Cache,之后运行一个抓取网站的工具,这类工具很多,例如wget、sitemaps生成器之类的,把整个网站抓一遍,即可在super-static-cache的目录获取到网站的静态化Html文件。

wget在Windows、Linux、Mac都有,用wget下载网站的命令是:

wget -m 网站地址

来源:月光博客


Public @ 2017-03-26 15:45:07

虚拟主机WordPress部署SSL注意事项(301跳转)

在为虚拟主机部署SSL证书时,需要注意以下事项: 1. 301跳转:在为WordPress站点部署SSL证书后,需要将所有HTTP的请求跳转到HTTPS,即需要设置301跳转。可以在.htaccess文件中添加以下代码: ``` RewriteEngine On RewriteCond %{HTTPS} off RewriteRule ^(.*)$ https://%{HTTP_HOST}%{

Public @ 2023-04-26 07:50:09

FTP上传大文件时连接重置或者中断,重新连接上传也出现同样情况处理办法

上传大文件的时候经常连接被重置或者中断,重新连接上传出现同样错误,具体错误如下图所示:blob.pngblob.png原因:机房防火墙设置了tcp空闲5分钟中断,如果使用被动模式上传较大的文件,上传速度比较慢时容易造成超时,所以连接会被中断重置。解决办法:将ftp软件设置为主动模式(port模式)进行连接上传即可。以下是几款常用FTP设置方式:1、LeapFTPblob.pngblob.png2、

Public @ 2018-12-05 15:45:59

Linux虚拟主机安装WordPress教程

我司虚拟主机支持一键安装WordPress程序,具体的操作步骤如下说明。环境要求虚拟主机操作系统推荐使用Linux开通MySQL数据库WordPress需要MySQL数据库支持,主机开通成功后可以在业务管理 - 虚拟主机管理 - 找到您的主机名 - 点击后面管理按钮进入主机管理面板。0.19849788867634466.png进入之后点击左侧获取赠品 - 获取免费的MySQL,MySQL开通成功

Public @ 2012-12-22 15:45:03

wordpress无法安装更新主题插件的解决办法

最近一段时间,国内无法正常访问WordPress官网,经常提示“429 Too Many Requests”,后台程序版本升级、主题、插件升级时常失败。目前发现一款非常好用的插件:WP-China-Yes,可以安装这个插件。下载解压,将目录上传到wp-content/plugins/,然后登陆网站后台启用插件。下载地址:1. WordPress官网地址:https://cn.wordpress.o

Public @ 2015-12-11 15:45:04

更多您感兴趣的搜索

0.576215s