Categories


Tags


Linux系统云服务器查看/启用网站日志

查看网站日志

BT环境

进入BT管理面板中,点击左侧“网站”-对应站点--点击“设置”-配置文件,查看access_log行 (access_log为网站访问日志 ,error_log为网站错误日志)

图片1.png

WDCP环境

进入wdcp点击左边“站点管理”-“站点列表”,找到要设置的站点,点站点后面对应的“编“按钮,勾中”开启访问日志“即可,日志文件目录 /home/web_logs

图片2.png

自建web环境

通过ssh方式远程登录服务器内,运行如下命令

netstat  -tnpl

查看监听80或443端口web服务的PID

图片3.png

运行如下命令

ll  /proc/2908/fd

图片4.png

/home/web_logs/xxx_access.log 即为访问日志。

查看网站配置文件

通过ssh方式远程登录服务器内,运行如下命令

netstat  -tnpl      # 查看监听80或443端口web服务的pid号

ll /proc/pid号/exe

图片5.png

可查出当前web服务目录(/www/server/nginx),进入到web服务目录下conf目录(命令:cd /www/server/nginx/conf ),查看nginx.conf (命令:vi nginx.conf ) 文件可查到站点配置文件所在路径

图片6.png

apache环境配置文件为httpd.conf (命令:vi httpd.conf)

图片7.png

进入对应路径目录(命令:cd  /www/server/panel/vhost/nginx/ )下即可看到相应网站的配置文件。如果配置文件较多,可以运行如下命令

grep 'xxx.com' *

搜索出对应的配置文件。

启用网站日志

Nginx

vi编辑站点配置文添加

图片.png

保存退出并重启nginx服务。

Apache

先按上述方式找到apache服务路径进入conf目录, 查看httpd.conf文件, 查看logFormat格式

图片.png

再vi 编辑站点配置文件,添加:

图片.png

保存退出并重启aapche服务。

来源:西部数码


Public @ 2010-04-07 15:32:48

远程桌面之终端服务器超出了最大允许连接数解决

出现这种情况的原因和解决办法。原因:用远程桌面链接登录到终端服务器时经常会遇到“终端服务器超出最大允许链接数”诸如此类错误导致无法正常登录终端服务器,引起该问题的原因在于终端服务的缺省链接数为2个链接,并且当登录远程桌面后如果不是采用注销方式退出,而是直接关闭远程桌面窗口,那么实际上会话并没有释放掉,而是继续保留在服务器端,这样就会占用总的链接数,当这个数量达到最大允许值时就会出现上面的提示。解决

Public @ 2015-07-20 16:13:30

访问网站出现Directory Listing Denied 是什么原因?

Directory Listing Denied是指服务器禁止访问该目录并列出其中的文件和目录。原因可能是服务器未设置默认文件或者未将文件列为默认文件,或者服务器设置了安全权限,只允许用户访问指定目录中的已知文件。如果您需要访问该目录,请检查服务器配置或联系管理员以获取更多帮助。

Public @ 2023-06-05 06:00:05

怎样看原始日志文件

原始日志文件通常以文本文件的形式存在。以下是一些底层操作系统上打开和查看日志文件的常见方法: 在Windows系统上: 1. 打开“开始”菜单,找到“运行”选项,并在其中输入“notepad.exe”命令。 2. 在记事本中,选择“文件”菜单,并选择“打开”选项。 3. 导航到原始日志文件所在的路径,用鼠标单击选中该文件,并单击“打开”按钮。 4. 使用记事本查看原始日志文件的内容。 在Un

Public @ 2023-05-26 23:50:18

什么是网站日志?网站日志分析怎么进行?

网站日志是指记录网站访问活动和其他相关信息的文件。它包含了网站的访问者数量、访问时间、访问来源、访问页面、访问设备等信息。网站日志分析是对这些日志进行统计和分析,以获取对网站访问情况和用户行为的深入了解。 网站日志分析可以通过以下步骤进行: 1. 收集日志:将网站生成的访问日志保存在服务器或第三方工具中。 2. 清理和格式化:对日志进行清理和格式化,去除无用信息,确保数据的准确性和一致性。 3.

Public @ 2023-07-24 22:00:30

更多您感兴趣的搜索

0.424033s